Actions

Difference between revisions of "VS-IMT Upgrade Stations"

From Zenitel Wiki

(Troubleshooting)
(Troubleshooting)
 
(7 intermediate revisions by the same user not shown)
Line 1: Line 1:
 
{{AEIPS}}
 
{{AEIPS}}
 +
 
This article describes how to upgrade (or downgrade) the firmware of Zenitel IP devices using the [[IMT|VS-IMT]] PC tool.
 
This article describes how to upgrade (or downgrade) the firmware of Zenitel IP devices using the [[IMT|VS-IMT]] PC tool.
 
+
__TOC__
<div style="text-align:left;"> <youtube width="300" height="180">3zihEBIEprc</youtube>  </div>
+
<div style="text-align:right;"> <youtube width="300" height="180">3zihEBIEprc</youtube>  </div>
 
<br><br>
 
<br><br>
 
==Prerequisites==
 
==Prerequisites==
Line 25: Line 26:
 
== Troubleshooting ==
 
== Troubleshooting ==
 
If the you get the response "'''Upgrade failed'''", check the following:
 
If the you get the response "'''Upgrade failed'''", check the following:
* Check point 7 above, in case your computer has multiple ethernet interfaces
+
* '''Computer with multiple ethernet interfaces''': Check point 7 above, in case your computer has multiple ethernet interfaces
* If the station is set to obtain IP address from a DHCP server, but there is no DHCP server present..
+
* '''No DHCP server present''': If the station is set to obtain IP address from a DHCP server (default), and there is no DHCP server present, the station will use a random 169.254.x.x address. Upgrade might fail in this situation. To rectify this, either set a static IP address, or connect the station to a network with a DHCP server present.
* If the station has an outdated Bootloader (a small software module used during startup), the upgrade will fail. You can check if that is the case by selecting the station from the list, and read the bootloader version from the Information and Status field:
+
* '''Old "bootloader" version''': If the station has an outdated Bootloader (a small software module used during startup), the upgrade will fail. You can check if that is the case by selecting the station from the list, and read the bootloader version from the Information and Status field:
  
 
[[File:IMT Failed.PNG|thumb|800px|left|Upgrade failed due to old bootloader software]]
 
[[File:IMT Failed.PNG|thumb|800px|left|Upgrade failed due to old bootloader software]]
 
<br style="clear:both;" />
 
<br style="clear:both;" />
  
If either the Bootloader and/or Bootenv version is from 2015, the upgrade will terminate with the failure message. If that is the case, the station must be updated using the "Configuration Manager".
+
If either the Bootloader and/or Bootenv version is from 2015, the upgrade will terminate with the failure message. If this is the case, the station must be updated using the "'''Configuration Manager'''" option on the start menu of the IMT tool.
 
 
 
 
 
 
 
 
  
  
 +
If a device fails to upgrade or in case of any other problems, see also [[VS-IMT Troubleshooting & Technical Background]].
 
<br>
 
<br>
 
<br>
 
<br>
 +
 +
=== Notes ===
  
 
{{note|'''Upgrade from Turbine ver. 3.x''':
 
{{note|'''Upgrade from Turbine ver. 3.x''':
Line 59: Line 59:
 
* If you have Turbine device with version 5.x, or an INCA device with version 2.10 or newer (i.e. IC-Edge), and want to use them in a Pulse system, you need to downgrade the Turbine to ver. 4.11.3.x, and the INCA station to version 2.9.3.x. Use the download links at the top of this article to get the firmware, and use the procedure described in this article to perform the downgrade}}
 
* If you have Turbine device with version 5.x, or an INCA device with version 2.10 or newer (i.e. IC-Edge), and want to use them in a Pulse system, you need to downgrade the Turbine to ver. 4.11.3.x, and the INCA station to version 2.9.3.x. Use the download links at the top of this article to get the firmware, and use the procedure described in this article to perform the downgrade}}
  
 
 
If a device fails to upgrade or in case of any other problems, see [[VS-IMT Troubleshooting & Technical Background]].
 
  
  
 
[[Category:VS-IMT]]
 
[[Category:VS-IMT]]

Latest revision as of 15:09, 31 May 2022

AEIPS.png

This article describes how to upgrade (or downgrade) the firmware of Zenitel IP devices using the VS-IMT PC tool.



Prerequisites

  • Download and install the VS-IMT tool on a Windows computer. Make sure you are using the latest version of the software.
  • Download the latest Device Firmware Package VS-IS_6.x.x.x.zip, and store it on your computer. Make a note of the location. Don't unzip the file. The VS-IS Device Firmware Package is a collection of firmware images for most types of Zenitel IP intercoms and devices.

Upgrade procedure

  1. Start IMT, select Discover & Upgrade from main menu
  2. Enter From - To IP address range
  3. Change credentials if default username/password is not used on the devices
  4. Press Search to start the discovery process
  5. When the search process is finished, select Import Image…, and browse to the VS-IS_6.x.x.x.zip file
  6. Select which devices to upgrade by Ctrl+Click (individual devices), Shift+Click (range of devices) or Ctrl+A (all devices). Selected devices are highlighted in blue color. The IMT will update up to 8 devices in parallel
  7. If your computer has several Ethernet interfaces, select the one which is on the same network as the Zenitel devices ("Choose TFTP server IP address")
  8. Press Upgrade
  9. The Status column shows the upgrade process. Wait for all upgrades to complete.The status will be reported Success when a device is up and running with the new firmware.


Discovery and Upgrade


Troubleshooting

If the you get the response "Upgrade failed", check the following:

  • Computer with multiple ethernet interfaces: Check point 7 above, in case your computer has multiple ethernet interfaces
  • No DHCP server present: If the station is set to obtain IP address from a DHCP server (default), and there is no DHCP server present, the station will use a random 169.254.x.x address. Upgrade might fail in this situation. To rectify this, either set a static IP address, or connect the station to a network with a DHCP server present.
  • Old "bootloader" version: If the station has an outdated Bootloader (a small software module used during startup), the upgrade will fail. You can check if that is the case by selecting the station from the list, and read the bootloader version from the Information and Status field:
Upgrade failed due to old bootloader software


If either the Bootloader and/or Bootenv version is from 2015, the upgrade will terminate with the failure message. If this is the case, the station must be updated using the "Configuration Manager" option on the start menu of the IMT tool.


If a device fails to upgrade or in case of any other problems, see also VS-IMT Troubleshooting & Technical Background.

Notes

Note icon Upgrade from Turbine ver. 3.x:
  • When upgrading from version 3.1 and later, one can update directly to the final version, e.g. vsft-4.11.3.0
  • Upgrade from version 3.0.3.5/3.0.3.6: First update to sti-prod-4.7.3.0, and finally vsft-4.11.3.0
  • Upgrade from version 3.0.3.4 or earlier: First update to tsi-3.0.3.5, then to sti-prod-4.7.3.0, and finally vsft-4.11.3.0


Note icon Flowire notes:
  • FCDC3 is supported as from IMT ver. 1.6.3.0
  • Flowire units cannot be upgraded at the same time as other device types. Flowire units must be upgraded separately.
  • Flowires will be upgraded sequentially, one-by-one
  • Upgrade of a Flowire device is disabled if the device has an IP Address in the range 169.254.1.x


Note icon Turbine Video Station TCIV-x notes:


Note icon IC-Edge vs Pulse systems:
  • In an IC-Edge system the minimum firmware requirement is Turbine ver. 5.x and INCA ver. 2.10.x.x. This is a requirement for all devices in the system.
  • In a Pulse system all devices must be running Turbine firmware 4.x and/or INCA firmware 2.9.x.x (or older versions)
  • If you have Turbine device with version 5.x, or an INCA device with version 2.10 or newer (i.e. IC-Edge), and want to use them in a Pulse system, you need to downgrade the Turbine to ver. 4.11.3.x, and the INCA station to version 2.9.3.x. Use the download links at the top of this article to get the firmware, and use the procedure described in this article to perform the downgrade