Actions

VS-IMT Upgrade Stations

From Zenitel Wiki

Revision as of 12:48, 16 January 2018 by Asle (talk) (How to upgrade IP Stations)
APS.png

This article describes how to upgrade the software of the Inca series and the Turbine series of intercom devices, as well as the Flowire to the latest version via the VS-IMT tool.

It is also possible to upgrade the software using the web interface of the station/Flowire:

Prerequisites

  1. Download and install the VS-IMT tool
  2. Download the desired image file. Don't unzip the file.
Turbine Image file download
Inca Image file download
Flowire Image file download

Run the station wizard and perform the discovery and the identify process. The next step in the wizard will then be the upgrade section.

Adding image files to library

ImportImage.png

Available Turbine images can be seen from drop-down menu of the same name. Adding additional images to the list can be performed with "Import image..." function.

Click on the button and navigate to .zip image previously downloaded from Zenitel site. This is recommended way to add software images.

Manually adding software images
See the VS-IMT Troubleshooting article.

Upgrade 

VS-IMT can upgrade all stations to the latest software. It is station type-aware and will use the correct image file for the upgrade. A built-in file transfer server can upgrade many stations in parallel which makes it the most efficient way to upgrade Vingtor-Stentofon IP stations (only Flowire devices will be upgraded sequentially, one-by-one).

Software image files for IP intercom stations need to be downloaded to the PC and imported into VS-IMT before starting the upgrade process. The Import image feature will extract the image into the VS-IMT software repository on the local disk.

Some upgrades of Turbine IP intercoms require specific image packages – sti-prod-4.x.x.x. The table below shows the correct Turbine image file versions to use.

Current version Desired version Image file to use What to do
3.0.3.4 or earlier 3.0.x.x tsi-3.0.x.x Normal upgrade
3.0.3.4 or earlier 4.2.0.0-4.7.3.0 tsi-3.0.3.5 and then sti-prod-4.x.x.x First, upgrade station to 3.0.3.5 and then to required 4.2.x.x/4.7.3.0 version.
3.0.3.4 or earlier 4.7.3.1+ tsi-3.0.3.5, then sti-prod-4.x.x.x and then sti-4.7.3.1+ First, upgrade station to 3.0.3.5, then to any 4.2.x.x/4.7.3.0 version and then to required 4.7.3.1+ version
3.0.3.5 / 3.0.3.6 4.2.0.0-4.7.3.0 sti-prod-4.x.x.x Normal upgrade.
3.0.3.5 / 3.0.3.6 4.7.3.1+ sti-prod-4.x.x.x and then sti-4.7.3.1+ First, upgrade station to any 4.2.x.x/4.7.3.0 version and then to required 4.7.3.1+ version.
3.1.x.x / 4.1.x.x / 4.2.x.x /4.7.x.x 4.2.x.x/4.7.x.x sti-4.x.x.x Normal upgrade. Bootloader will be upgraded if required by target version.
3.1.x.x / 4.1.x.x / 4.2.x.x /4.7.x.x 4.2.x.x/4.7.x.x (forced bootloader upgrade) sti-4.x.x.x Choose "Perform boot environment upgrade (forced) and standard upgrade"
3.1.x.x / 4.1.x.x / 4.2.x.x /4.7.x.x 4.2.x.x/4.7.x.x (only bootloader upgrade) sti-4.x.x.x Choose "Perform boot environment upgrade only"

Note: Upgrading Turbines with software version 3.0.3.4 or earlier requires a two-step upgrade. They first need to be upgraded with tsi-3.0.3.5 image and then with sti-prod-4.2.x.x or sti-prod-4.7.x.x image.

Trying to upgrade 3.0.3.4 directly with sti-prod-4.2.x.x or sti-prod-4.7.x.x will result with "unsupported" warning message.

IMT-StiProd.png


How to upgrade IP Stations

  1. Select target software versions in the Station software images panel:
    Select a desired software version used for the upgrade of every device type type: Turbine, INCA, Dual-Display and Flowire.
  2. Check the Software and Upgrade To column to decide which stations to upgrade
  3. Select boot environment upgrade option. By default Perform boot environment upgrade (if required) and standard upgrade option is selected. This is recommended setting for all use cases. Upgrades including bootloader update will be run at the end
  4. Start Upgrade:
    Mark multiple (Shift+click or Ctrl+click) or all (Ctrl+a) stations for multi-selection and click the Upgrade button to initiate the upgrade process.
Upgrade stations step


Note icon {{{1}}}


Turbine firmware upgrades that require a boot/environment upgrade are marked with warning icon because such upgrades are risky in case something goes wrong in the upgrade process (power outage, network down, etc.). DO NOT power down stations or make any network changes while the upgrade is in progress. Boot environment upgrade can also be forced on stations that do not require boot/environment upgrade by using other options under "Boot environment upgrade options".


Once upgrade is initiated, wait for all upgrades to complete. IMT pushes new software image to all selected stations and initiates upgrade on each station. Once image is flashed to station and station is booted again, IMT checks if station got new version and reports that in "Status" column". You may run as many upgrades in a row as you want. And in case upgrade fails, you may always try to run upgrade again on the same station(s).

Station Upgrade in Progress


If a station fails to upgrade or in case of any other problems, see VS-IMT Troubleshooting & Technical Background.

How to upgrade Flowire stations

Flowires cannot be upgraded together with stations.

  • Select all Flowires and press upgrade.
  • The application will upgrade them all one by one.

Upgrade Stations already included in the project

Devices in an existing project can be upgraded directly without running the wizard. To start upgrade:

  • Select File -> Upgrade Stations (or press CTRL+U)

Upgrade stations window behaves the same as the Upgrade stations step in discovery wizard.

ImtUpgradeStationsMain.png



Previous step: VS-IMT Identify Stations

Next step: VS-IMT Configure Stations